Merge tag 'edgar/xilinx-next-2022-09-21.for-upstream' of https://github.com/edgarigl...
[qemu.git] / tools / meson.build
1 have_virtiofsd = get_option('virtiofsd') \
2     .require(targetos == 'linux',
3              error_message: 'virtiofsd requires Linux') \
4     .require(seccomp.found() and libcap_ng.found(),
5              error_message: 'virtiofsd requires libcap-ng-devel and seccomp-devel') \
6     .require(have_vhost_user,
7              error_message: 'virtiofsd needs vhost-user-support') \
8     .disable_auto_if(not have_tools and not have_system) \
9     .allowed()
10
11 if have_virtiofsd
12   subdir('virtiofsd')
13 endif