arm tcg cpus: Fix Lesser GPL version number
[qemu.git] / tools / meson.build
1 have_virtiofsd = (targetos == 'linux' and
2     have_tools and
3     'CONFIG_SECCOMP' in config_host and
4     'CONFIG_LIBCAP_NG' in config_host and
5     'CONFIG_VHOST_USER' in config_host)
6
7 if get_option('virtiofsd').enabled()
8   if not have_virtiofsd
9     if targetos != 'linux'
10       error('virtiofsd requires Linux')
11     elif 'CONFIG_SECCOMP' not in config_host or 'CONFIG_LIBCAP_NG' not in config_host
12       error('virtiofsd requires libcap-ng-devel and seccomp-devel')
13     elif not have_tools or 'CONFIG_VHOST_USER' not in config_host
14       error('virtiofsd needs tools and vhost-user support')
15     endif
16   endif
17 elif get_option('virtiofsd').disabled() or not have_system
18   have_virtiofsd = false
19 endif
20
21 if have_virtiofsd
22   subdir('virtiofsd')
23 endif