xen: Support new libxc calls from xen unstable.
authorAnthony PERARD <anthony.perard@citrix.com>
Fri, 25 Feb 2011 16:20:34 +0000 (16:20 +0000)
committerAlexander Graf <agraf@suse.de>
Sun, 8 May 2011 08:09:59 +0000 (10:09 +0200)
commitd5b93ddfefe63d5869a8eb97ea3474867d3b105b
tree59e371524ce2dc25b9a9940f4a3c811e7d0aef1f
parentce6bc29458e9e0a95da8aa192fc117125132dc2a
xen: Support new libxc calls from xen unstable.

This patch updates the libxenctrl calls in Qemu to use the new interface,
otherwise Qemu wouldn't be able to build against new versions of the
library.

We check libxenctrl version in configure, from Xen 3.3.0 to Xen
unstable.

Signed-off-by: Anthony PERARD <anthony.perard@citrix.com>
Signed-off-by: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
Acked-by: Alexander Graf <agraf@suse.de>
Signed-off-by: Alexander Graf <agraf@suse.de>
configure
hw/xen_backend.c
hw/xen_backend.h
hw/xen_common.h
hw/xen_disk.c
hw/xen_domainbuild.c